Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|

Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

ylorenza
Hi yan,

I finnally can move from 4.7 version to the latest (and greatest) 5.6.1 version.


I try to use in a first time the "Quick and easy" way with the setup-pre-510.sh script.
But i don't understand how i can configure zookeeper and glu agent with the generated package.

In 4.7.x and in 5.0.0 we have in the package the setup directory with "the setup-agent.sh" and "setup-zookeeper.sh" but I can't find them with the new package.

Did I miss something ?

If possible, i prefere migrate in 2 time : first the new version with old package, and then the new install way.

Thanks for you're help

Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

frenchyan
Administrator
The setup-agent.sh and setup-zookeeper.sh scripts were designed to setup the agents the first time. If you are upgrading, you should not need them. But if you do, you can safely use the ones from 4.7.x.

Yan
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

ylorenza
That's what's I did.

Thank for your help
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

ylorenza
Juste another question :

With glu 4.7.3, from a fresh install i can do a stop with the console webapp to have just the install and the configuration step.

But i can't now, there is no plan to do that.

I just look here http://pongasoft.github.io/glu/docs/latest/html/glu-script.html#glu-script-state-machine
and for me that must work.

it seems normal to you ?
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

frenchyan
Administrator
I don't think I understand what you are asking. 

"there is no plan to do that". What is "that" referring to?
What does: "that must work" refer to?
Yan
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

ylorenza
Sorry, it was not so clear to me too (and it was with the rest api and not the webapp ....  so sorry)

forget my previous message, I try to describe the problem in this one (I work on it, so I have more information)


With the rest api, when i try to create a plan

with planAction=stop, I have a 204 http return status on 5.6.1 and a 201 http return status on 4.7.1

with planType=transition&state=stopped it's 201 with 4.7.3 and 5.6.1

So I just need to rewrite my cli and use the planType=transition&state=stopped way.

but it's still strange...

thank in advance,
Yannick
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

frenchyan
Administrator
Would you mind posting what kind of content you get (the body of the response) when the status is 201? It is certainly odd that you get 2 different results but it would help confirming what is going on.

Thanks
Yan

On Wed, Aug 26, 2015 at 11:55 PM, ylorenza [via glu] <[hidden email]> wrote:
Sorry, it was not so clear to me too (and it was with the rest api and not the webapp ....  so sorry)

forget my previous message, I try to describe the problem in this one (I work on it, so I have more information)


With the rest api, when i try to create a plan

with planAction=stop, I have a 204 http return status on 5.6.1 and a 201 http return status on 4.7.1

with planType=transition&state=stopped it's 201 with 4.7.3 and 5.6.1

So I just need to rewrite my cli and use the planType=transition&state=stopped way.

but it's still strange...

thank in advance,
Yannick


If you reply to this email, your message will be added to the discussion below:
http://glu.977617.n3.nabble.com/Glu-migration-from-4-7-3-to-5-6-1-and-zookeeper-configuration-tp4026944p4026960.html
To start a new topic under glu, email [hidden email]
To unsubscribe from glu, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

ylorenza
Glad to help

ps  : it works perfectly with the planType

5.6.1

ylorenza@pc-0888:~$ curl -v -u "admin:xxx" --data "planAction=stop" http://localhost:8085/console/rest/v1/stet-glu/plans
* Connected to localhost (::1) port 8085 (#0)
* Server auth using Basic with user 'admin'
> POST /console/rest/v1/stet-glu/plans HTTP/1.1
> Authorization: Basic YWRtaW46YWRtaW4=
> User-Agent: curl/7.35.0
> Host: localhost:8085
> Accept: */*
> Content-Length: 15
> Content-Type: application/x-www-form-urlencoded
>
* upload completely sent off: 15 out of 15 bytes
< HTTP/1.1 204 no plan created (no delta)
< Date: Mon, 31 Aug 2015 12:49:59 GMT
< Set-Cookie: JSESSIONID=98w60v17f3n71w8btanin04dc;Path=/console
< Expires: Thu, 01 Jan 1970 00:00:00 GMT
< Set-Cookie: rememberMe=deleteMe; Path=/console; Max-Age=0; Expires=Sun, 30-Aug-2015 12:50:00 GMT
< Content-Type: text/html;charset=UTF-8
* Server Jetty(8.1.10.v20130312) is not blacklisted
< Server: Jetty(8.1.10.v20130312)



4.7.1

ylorenza@pc-0888:~$ curl -v -u "admin:xxx" --data "planAction=stop" http://localhost:8085/console/rest/v1/stet-glu/plans
* Connected to localhost (::1) port 8085 (#0)
* Server auth using Basic with user 'admin'
> POST /console/rest/v1/stet-glu/plans HTTP/1.1
> Authorization: Basic YWRtaW46YWRtaW4=
> User-Agent: curl/7.35.0
> Host: localhost:8085
> Accept: */*
> Content-Length: 15
> Content-Type: application/x-www-form-urlencoded
>
* upload completely sent off: 15 out of 15 bytes
< HTTP/1.1 201 Created
< Date: Mon, 31 Aug 2015 13:03:00 GMT
< Set-Cookie: JSESSIONID=7b00ngthu7b5jxdszxw1murv;Path=/console
< Set-Cookie: rememberMe=deleteMe; Path=/console; Max-Age=0; Expires=Sun, 30-Aug-2015 13:03:00 GMT
< Location: http://localhost:8085/console/rest/v1/stet-glu/plan/e8abafa0-384d-471d-a8ea-d55b7ef78cdd
< Content-Type: text/html;charset=UTF-8
< Set-Cookie: fabric=O-Lg1z680bLkK-;Path=/console;Expires=Tue, 30-Aug-2016 13:03:00 GMT
< Expires: Thu, 01 Jan 1970 00:00:00 GMT
< Transfer-Encoding: chunked
* Server Jetty(8.1.10.v20130312) is not blacklisted
< Server: Jetty(8.1.10.v20130312)
<
* Connection #0 to host localhost left intact
Reply | Threaded
Open this post in threaded view
|

Re: Glu migration from 4.7.3 to 5.6.1 and zookeeper configuration

frenchyan
Administrator
With 4.7.1 you get a 201 status code and a Location header. Can you do a GET on this location and post the content?

Thanks
Yan